みずりゅの自由帳

主に参加したイベントやソフトウェア技術/開発について記録しています

Nerves

nerves_system_rpi0はなぜv2.0.0になるのか

Nerves関連の備忘。Elixir製IoTフレームワーク「Nerves」のRaspberry Pi Zeroのコンフィグ設定を行う「nerves_system_rpi0」でバージョン2の話が出ているので記録しておく。*12020年10月14日8:27JSTに、nerves_system_rpi0のv2.0.0-rc.1のリリースされていま…

「Elixir/Nerves入門!堅牢なIoT Edgeデバイスプログラミングをお手軽に」に参加しました

2020/07/10にオンラインイベントである『Elixir/Nerves入門!堅牢なIoT Edgeデバイスプログラミングをお手軽に』に参加しました。algyan.connpass.comこちらは、IoT ALGYAN(あるじゃん)( https://algyan.connpass.com/))様の開催イベントとなっております…

「Elixirへのいざない」商業版の出版について(ウラ話あり)

2020年6月5日、「Elixirへのいざない」という商業書籍を出版しました。 インプレスR&Dさんの「技術の泉」シリーズとしての出版です。 技術書典7で頒布した技術同人誌「PhoenixLiveViewとNervesをさわるElixirへのいざない」を底本した書籍となっています。 …

備忘:Elixir関連のHexdocsのURL

備忘。 Elixir関連のHexdocsを参照するのにググることが多くなってきたので、リンク先を記録しておく。

Nerves1.6.1対応のためにfwupをアップグレードする

ElixirのIoTフレームワークであるNervesですが、日本時間の2020年3月20日にバージョン1.6.1がリリースされています。 バージョンの1.6.0から1.6.1からの差分として、以下の2点があります。 「nerves_bootstrap」のバージョン1.8に対応。*1 「fwup」の要求バ…

技術書典8向けに書いた「Elixirへのいざない2」PDF版をBOOTHで頒布しています

2020年2月29日から、技術書典8向けに執筆した「 Elixirへのいざない2 〜もっとNervesをさわる〜 」をBOOTHにて頒布しています。こちらの表紙が目印です。PDF版のみで、価格は500円。表紙込の71ページです。 BOOTH内で「技術書典 elixir」で検索すると表示さ…

技術書典8向けに書いた「Elixirへのいざない2」PDF版の無料お試しダウンロードをはじめました

技術書典8、残念ながら中止になってしまいました。techbookfest.orgとはいえ、規模と集客力/影響力などを考えると致し方ないでしょう。 むしろ、このような苦渋の決定をした技術書典の運営の英断を支持いたします。さて、本題です。以前の記事で書いた通り…

技術書典8でElixir本「Elixirへのいざない2」を頒布予定です

技術書典8のサークル配置が決まったので、自分自身の鼓舞のためにも記述しておきます。2020年3月1日の技術書典8「Elixirへのいざない2〜もっとPhoenixLiveViewとNervesをさわる〜」というタイトルのElixir本を頒布する予定です。タイトルが長いので、「えり…

IoTつくるよ!2 〜みんなで盛り上げるIoT博覧祭〜 に行ってきました。

2019年11月30日、「IoTつくるよ!2」に参加してきました。 2となっている事から分かるように、第2回目の開催だそうです。1回目は昨年とのこと。 若干偏った内容にはなっていますが、参加してきた内容を記録しておきます。 algyan.connpass.com

技術書典7でElixir本「PhoenixLiveViewとNervesをさわるElixirへのいざない」を頒布します。

「PhoenixLiveViewとNervesをさわるElixirへのいざない」というタイトルのElixir入門本を2019年9月22日の技術書典7で頒布する予定です。タイトルが長いので「えりいざ」とでも略してください。本のタイトルの通り、Phoenix LiveViewとNervesと呼ばれるプログ…

Nerves1.5.0からasdfの設定先が.bashrcに変更されている

Nervesのインストール手順を見ていて気づいた点。Nervesの1.5.0がリリースされて、「Erlang 22」「Elixir 1.9.0-otp-22」対応となった。 そのため、Nervesのインストール手順では、asdf経由でインストールするErlang とElixirのバージョンは、それぞれ22と1.…

nerves_bootstrap1.6.0ではElixir1.9を要求される

※本記事は、2019.07.15時点の情報で記述しています。備忘。「mix local.nerves」コマンドを実行してnerves_bootstrap のバージョンを上げてしまい、「mix nerves.new」コマンドが実施できなくなった。バージョンアップしたnerves_bootstrapが利用できるElixi…